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ABSTRACT

This guide is intended to assist users in the initial setup and demonstration of the Getting Started with
WLAN Station application. The guide explains how to install an Integrated Development Environment
(IDE), and then compile, download and debug Getting Started with WLAN Station.

1 Introduction

1.1 Prerequisites
The user should have the following items:
+ One CC3100BOOST
¢ One CC31XXEMUBOOST or MSP430F5529 Launchpad
e An 802.11b/g/n Wireless Access Point (AP)
e A computer running Microsoft® Windows® 7 or XP operating systems.

2 Getting Started

2.1 Download and Install Software
Download and install the following software:
* (CC3100 SDK package http://www.ti.com/tool/cc3100sdk
— This guide assumes the use of the default installation folder CATNCC3100SDK_1.1.0\.

2.2 Update Service Pack

If the board being used is not already flashed with the service pack for SDK 1.1.0, the latest service pack
for SDK 1.1.0 needs to be flashed on the CC3100. The latest service pack can be downloaded from
http://www.ti.com/tool/cc3100sdk. Refer to the UNIFLASH Quick start guide for details on flashing the
service pack to the CC3100

(http://processors.wiki.ti.com/index.php/CC31xx_%26 CC32xx UniFlash#Service Pack Programming).
Details on setting up the hardware for flashing can be found in Section 3.1.

SimpleLink is a trademark of Texas Instruments.
Wi-Fi is a registered trademark of Wi-Fi Alliance.
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3 Getting Started with SimpleLink Studio

3.1 Configure Boards
1. The jumpers on the CC3100BOOST should be connected as shown in Figure 1.
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Figure 1. CC3100BOOST
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2. The jumpers on the CC31XXEMUBOOST should be connected as shown in Figure 2.
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Figure 2. CC31XXEMUBOOST
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3. Connect the CC3100BOOST to the CC31XXEMUBOOST as shown in Figure 3.

Figure 3. Connect the CC3100BOOST to the CC31XXEMUBOOST

4. Connect the J6 port CC31XXEMUBOOST to the PC using the provided micro-USB cable.

5. The CC3100BOOST will now be visible in the Device Manager as shown in Figure 4. The user may
see two COM ports instead of four.
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Figure 4. Device Manager

Run the Software

The Getting Started with WLAN Station example uses SimpleLink Studio. This example performs the
following functions:

1.

S

Program restores WLAN configuration to factory default
Prompts the user for the SSID of an AP to connect to.
Prompts the user for the security type.

Prompts the user for the password to the AP.

Attempts to acquire an IP address through DHCP.
Attempts to reach the internet.

Option 1. Microsoft Visual Studio:

1.

4.
5.

Download and install Microsoft Visual Studio Express 2010 from http://www.visualstudio.com/en-
us/downloads/download-visual-studio-vs#DownloadFamilies 4.

Open Microsoft Visual Studio Express, and select File>Open>Project/Solution.

Navigate to CA\TNCC3100SDK_1.1.0\cc3100-
sdk\platform\simplelinkstudio\example_project_vs\getting_started_with_station, and open
getting_started.sin.

Select Build>Build Solution from the menu.
When building is complete, select Debug>Start Debugging from the menu.

Option 2. Eclipse:

1.

Download and install the latest version of Java: https://www.java.com/en/download/. Install the correct
version for the system (64-bit or 32-bit).
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2. Download and Extract Eclipse from http://www.eclipse.org/downloads/. Choose the Eclipse IDE for
C/C++ Developers package. Install the correct version for the system (64-bit or 32-bit).

3. Download and install MinGW from
http://sourceforge.net/projects/mingw/files/latest/download?source=files. During installation, make sure
you have the following configurations selected:

(a) Set the installation location as C:\\MinGW.

(b) In the MinGW Installation Screen, select packages for mingw32-base and mingw32-gcc-g++ as
shown in Figure 5.

- —
Installation Package Settings Help
Basic Setup Package Class  Installed Version Repository Version  Description
All Packages . . . . .

g D mingw-developer-toolkit bin 2013072300 An MSYS Installation for MinGW Developers (meta)
mingw32-baze bin 2013072200 A Basic MinGW Installation
D mingw32-gcc-ada bin 4.8.1-4 The GNU Ada Compiler
D mingw32-gcc-fortran bin 4.8.1-4 The GNU FORTRAN Compiler
Wl minows2-occa++ Ibin [ [48.1-4 The GNU C++ Compiler
[ Unmark 4.8.1-4 The GNU Objective-C Compiler
|: Mark for Installation 2013072300 A Basic M5YS Installation (meta)
Mark for Reinstallation
4 Mark for Upgrade 1 = | o
= Mark for Removal
|— ) e Installed Files | Versions

The GNU C++ Compiler
This package provides the MinGW implementation of the GNU C++ language compiler.

This i= an optional component of the MinGW Compiler Suite; you reguire it only if you wish to compile programs written in the C++
language.

Figure 5. MinGW Installation Screen

(c) After selecting the packages, choose Installation>Apply Changes from the menu, then press Apply.
(d) Select Installation>Quit from the menu to quit the installer.

4. After a successful MinGW installation, add its path (c:\MinGW\bin\) to the Windows environment
variable path by going into Control Panel>System>Advanced System Settings>Environment Variables.
Under System Variables, select PATH and press Edit. Append “;C:\MinGW\bin\" to the end of the line
and press OKk.

5. Open Eclipse by running eclipse.exe from the extracted Eclipse folder.

6. In the "Select a workspace," choose your desired workspace directory (for example:
C:\Users\myself\Desktop\eclipse_workspace). This directory should be different from the user's other
versions of Eclipse.

7. From the menu select File>New>Makefile Project with Existing Code.
8. Enter ‘Getting_started’ as the project name.

9. For Existing Code Location, enter C\TNCC3100SDK_1.1.0\cc3100-
sdk\platform\simplelinkstudio\example_project_eclipse\getting_started_with_station.

10. For Toolchain for Indexer Settings, choose “MinGW GCC” as shown in Figure 6.
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Import Existing Code

Create a new Makefile project from existing code in that same directory

Project Mame
Getting_started

Existing Code Location

lelinkstudiot\example_project_eclipse\getting_started_with_station

Languages

C C++

Toolchain for Indexer Settings

<nones

Cross QICC

Cygwin GCC

GMHU Autotools Toolchain
Microsoft Visual C++

MinGW GCC

Show only available toclchains that support this platform

Cancel

Figure 6. Import Existing Code

11. Press Finish.
12. Select Window>Show View>Project Explorer from the menu.
13. Select the Getting_started project in the Project Explorer, and select File>Properties from the menu.
14. In the Project Explorer window, right click on <Project_Folder_Name>, then select Property.
15. Click the C/C++ Build menu and do the following:
(a) Uncheck Use the default build command.
(b) Type mingw32-make -f Makefile in Build command.
(c) Uncheck Generate Makefiles automatically.
(d) Set the Build Directory as: ${workspace_loc:/Getting_started}
16. Expand the C/C++ Build menu, and select Tool Chain Editor. Under Current Builder, Select "Gnu
Make Builder", then click Apply.
17. Slelkect E?vironment in the C/C++ Build menu. Make sure the value of MSYS_HOME is empty, then
click Apply.

10
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18. Click the C/C++ General menu, and select Paths and Symbols. Under the Includes tab, in the
Languages column, select GNU C. Press the Add button to add the directory:

C:ATNCC3100SDK_1.1.0\cc3100-sdk\simplelinkiinclude.

Build Variables
Environment

-~
= Properties for Getting_stated =~ - . . - - l [=] | &3 |
type filter text Paths and Symbols S v -

> Resource
Builders
4 C/C++ Build Configuration: [Default [ Active ] "l ’Manage Configurations...

)

Legging (= Includes | # Symbols | =11 Librariesl [® Library Paths | 2 Source Location | = Output Locatiq * | ©
Settings
Tool Chain Editor Languages Include directories Add...
4 C/C++ General I 5 B
Assembly 12 CATINCC3100S DK\ec 3100-sdk\simplelink\include :
> Code Analysis GMU C
Decumentation -
GMNU C++ Delete
S | Delete |
Indexer
Language Mappings P
Paths and Symbols = i
Preprocessor Include P: _ ] Move Down
Profiling Categories I The selected folder does not exist or not accessible.
Project References [#] Show built-in values
Run/Debug Settings ) - .
% Import Settings... | | 5 Export Settings...
: Task Repository [ B mpo 122 l [ < HXpo 1S
WikiText
- ™ - [Restore Defaults.l [ Apply
'f_?:l [ OK l [ Cancel

Figure 7. Paths and Symbols
19. Press OK.

20. To fix a known bug in Eclipse console output, add the following line of code to the beginning of the

main function:

setvbuf(stdout, NULL, _IONBF, 0);
21. Save the file, and select Project>Clean from the menu.
22. Select the Getting_started project and press OK.

23. Select the Getting_started project from Project Explorer, and from the menu select Project>Build

Project.
24. Press Ctrl+F11 to start the program.
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4 Getting Started with the MSP430F5529
4.1 Configure Boards
1. The jumpers on the CC3100BOOST should be connected as shown in Figure 8.
Figure 8. CC3100BOOST
12 CC3100 SimpleLink™ Wi-Fi® and loT Solution Getting Started Guide SWRU375B—June 2014 —Revised March 2015
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2. The jumpers on the MSP430F5529 Launchpad should be connected as shown in Figure 9.
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Figure 9. Jumpers on the MSP430F5529 Launchpad
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3. Connect the CC3100BOOST to the MSP430F5529 Launchpad as shown in Figure 10.

Figure 10. Connect the CC3100BOOST to the MSP430F5529 Launchpad

4. Connect a Micro-USB cable from J7 on the Boosterpack to the Windows PC, and connect a Micro-
USB cable from J401 on the MSP430F5529 Launchpad to the Windows PC.

4.2 Run the Software

The example shown provides output via UART. To see the output from the program, download Tera Term
(or similar software) from this link: http://en.sourceforge.jp/projects/ttssh2/releases/
Option 1. Code Composer Studio (CCS):

1. Download and run the Code Composer Studio 6.0.1 (CCS) installation wizard (ccs_setup_win32.exe)
from the Tl website or from the CCS Wiki page. Must be Version 6.0.1.00040 or later. When prompted
to select processor support, select the ‘MSP Ultra Low Power MCUs’ processor support option. The
remaining options for the installer should be left as the default. Installation may take up to an hour.

2. Open CCS, and choose File>Import from the menu. Under C/C++, choose CCS Projects.

3. Under Select Search Directory, enter the path: CATNCC3100SDK_1.1.0\cc3100-
sdk\platform\msp430f5529Ip\example_project_ccs.

4. Check the project getting_started_with_wlan_station and press Finish.
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&

x» Import CCS Eclipse Projects

Select CC5 Projects to Import
Select a directory to search for existing CC5 Eclipse projects.

@ Select search-directony:  CAENCC3I1005DK_1.1.04cc3100-5d K\ platform’ Browse...

(71 Select archive file: Browse...
Discovered projects:
[ &7 antenna_selection [CAtHCC310050K_1.1.00cc3100-sdk\plal = Select All |

[C] & connection_policies [C:\tCC310050K_1.1.00cc3100-sdkhp
[T 57 email_application [C:\t\CC31005DK_1.1.00cc3100-sdk\plat| = || | Deselect All
[ =7 enterprise_network_connection [C\HNCC310050K 1,100 e
[C] & file_operations [C:AtNCC310050K_1.1.00cc3100-sdkhplatfor —
[C] &0 get_time [C:AtitCC310050K_1.1.00cc3100-sdi platformims
[ &7 get_weather [C:\tNCC310050K_1.1.04%cc3100-sdk\platform!’ I
[ 57 getting_started_with_wlan_ap [C:\t"CC310050K_1.1.00cc31
T getting_started_with_wlan_station [C:\iCC310050K 110
[C] &0 http_client [C:AtiVCC3100S0K_1.1.00cc3100-sdikd platformin
[ & http_server [C:\NCC310050K_1.1.00cc3100-sdk\platform’r -
1 | (1] 3

Refresh

[]#Automatically import referenced projects found in same search-directory:

Copy projects into workspace

Open the Resource Fxplorer and browse available example projects...

Cancel

@ Finish ]

Figure 11. Select CCS Projects to Import

5. Open the sI_common.h file located at the path CA\TNCC3100SDK 1.1.0\cc3100-
sdk\examples\common\.

6. Edit sl_common.h to use the SSID, security type and security key of the Access Point being used. Edit
the macros SSID_NAME, SEC_TYPE and PASSKEY to contain the Access Point’s information as
shown in Figure 12. The security types supported for this demo are WPA/WPA2, WEP (5/13 ASCII),
and Open. WEP supports key index 1 only. For Open security, define SEC_TYPE as
SL_SEC_TYPE_OPEN. For WPA and WPAZ2 security, define it as SL_SEC_TYPE_WPA. For WEP
security, define it as SL_SEC_TYPE_WEP.
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# Values for below macros shall be modified per the access-point's # Values for belovw macros shall be modified per the

# Simplelink device will conpect to following AP when the applicatin  # Simplelink device will connect te following AP whe

#define SSID NAME "<ap name>" /% Access poinpt name to | #define S5ID NAME "Your AP Name Here" /

#define SEC_TYFE 5L_SEC TYFE_OFEN /* Secur T, the | #define SEC_TYPE 5L_SEC_TYFE_WEA /% Securlt
#define PRS5KEY " /* Passvura LI g¥ase of 5 #define PASSKEY "Your AP Security Key Here™

FUSLLIE FAJIALL LEN my ourienjralsancr) /% Passvord length in ca. guaellile FAJORLI_LEN Ly JLOLEINERIOALL) /° Fassv¥d

Figure 12. Define SSID_Name
7. Select the getting_started_with_wlan_station project in Project Explorer and select Project>Build
Project from the menu.

8. Launch Tera Term, and create a new serial connection to the MSP430F5529 Launchpad COM port as
shown in Figure 13. The baud rate should remain at 9600.

9. Press Fl11lon the CCS window to start debugging.

I Tera Term - [disconnected] VT = | E 2

File Edit 54 Tera Term: New connection

Ll e -
TCH{IP myhost.example.com

History
Telnet

55H SS5H?2
Other

22

UNSPEC

@ Serial Port: |COM7: MSP Application UART1 [COM, v|

[ oK l | Cancel | | Help |

Figure 13. Launch Tera Term

10. If the CC3100 successfully completes all steps, the serial output appears as shown in Figure 14.

16 CC3100 SimpleLink™ Wi-Fi® and 10T Solution Getting Started Guide SWRU375B—June 2014 —Revised March 2015
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% COM53:9600baud - Tera Term VT ESR e

File Edit Setup Control Window Help

Getting started with station application — Uersion 1.2.8

Device is configured in default state

Device started as STATION

Connection established w/ AP and IP iz acquired
Pinging...t

Device successfully connected to the LAMN

Device successfully connected to the internet

Figure 14. Tera Term VT

Option 2. IAR Workbench

1. Install IAR Workbench for MSP430 version 6.20 or later: http://www.iar.com/en/Products/IAR-
Embedded-Workbench/TI-MSP430/.

2. Open IAR Workbench and select File>Open>Workspace from the menu.

3. Select the project: CATNCC3100SDK_1.1.0\cc3100-
sdk\platform\msp430f5529Ip\example_project_iar\getting_started_with_wlan_station\
getting_started_with_wlan.eww.

4. Open the sl_common.h file located at the path C:\TNCC3100SDK_1.1.0\cc3100-
sdk\examples\common\.

5. Edit sl_common.h to use the SSID, security type and security key of the Access Point being used. Edit
the macros SSID_NAME, SEC_TYPE and PASSKEY to contain the Access Point’s information as
shown in Figure Figure 15. The security types supported for this demo are WPA/WPA2 and Open. For
Open security, define SEC_TYPE as SL_SEC_TYPE_OPEN. For WPA and WPA2 security, define it
as SL_SEC_TYPE_WPA.

* Values for belowv macros shall be modified per the access-point's * Values for belovw macros shall be modified per tLhe
* Simplelink device will connect to following AP when the applicati * Cimplelink device will connect bto followving AP whe
#define 551D NAME "<ap_namex" * Access poipt name to | #define 551D NRME "Your AP Name Here™ /
#define SEC_TYFE SL_SEC TYFE OFEN £ Cecur %, the | #define SEC_TYPE SL_SEC TYPE WERL /* Secur t
#define FASSKEY /* Passwora Lf gfase of 5 #define PRSSEEY "¥our AP Security Key Here™

FUSLLIE FAJIALI_LLN Iy _SLLLEN(FAJIALL) * Password length 1n ca, #FucLlllf FAIJALI_LLN Iy SLOLENNEFAIOALI) /" Fassw¥o

Figure 15. Macro Definition of SSID_Name

6. Select Project>Rebuild All from the menu.

7. Launch Tera Term, and create a new serial connection to the MSP430F5529 Launchpad COM port as
shown in Figure 16. The baud rate should remain at 9600.

8. After building is finished, select Project>Download and Debug from the menu to start debugging.
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% Tera Term - [disconnected] VT = | B 2

File Edit 5§ Tera Term: Mew connection l&]

TCF{IP myhost.example.com

History
Telnet

55H SS5H?2
Other

22

UNSPEC

@ Serial Port: | COM7: MSP Application UARTI [COM; ~ |

|_ OK | | Cancel | | Help |

Figure 16. Launch Tera Term

9. If the CC3100 successfully completes all steps, the serial output appears as shown in Figure 17.

| COMS53:9600baud - Tera Term VT B

File Edit Setup Control Window Help

Getting started with station application — Uersion 1.2.8

Device is configured in default state

Device started asz STATION

Connection establizhed w/ AP and IP iz acqguired
Pinging...t

Device successfully connected to the LAN

Device successfully connected to the internet

Figure 17. Tera Term VT
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www.ti.com Summary

5 Summary

After the development environment has been set up, see the following resources for further assistance in
development:

e CC3100 Programmer's Guide — This guide contains information on how to use the SimpleLink API for
writing WLAN-enabled applications.

» Uniflash — The Uniflash tool is used for manually storing files on the external serial flash. This includes
the SimpleLink firmware patch file and any configuration files, security certificates, web pages, and so
forth.

» CC3100 Wiki — All information and tools for the CC3100, including the above, can be found on the
CC3100 Wiki page.

6 Acronyms Used
STA — Wi-Fi Station
AP — Wi-Fi Access Point
WLAN — Wireless LAN
CCS — Code Composer Studio
GCC — GNU Compiler Collection

SWRU375B-June 2014 —-Revised March 2015 CC3100 SimpleLink™ Wi-Fi® and loT Solution Getting Started Guide 19

Submit Documentation Feedback
Copyright © 2014-2015, Texas Instruments Incorporated


http://www.ti.com
http://www.ti.com/lit/pdf/SWRU368
http://processors.wiki.ti.com/index.php/CC31xx_%26_CC32xx_UniFlash_Quick_Start_Guide
http://processors.wiki.ti.com/index.php/CC31xx_&_CC32xx
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU375B

I3 TEXAS

INSTRUMENTS

Revision History www.ti.com
Revision History
Changes from A Revision (July 2014) to B Revision Page
L O o To =1 (=0 0 G I 0 0 00 4
LI U T T o1 (=To T 4= o =N 15
LB U T T o (=T T 0= o = 17
L O o To o (=0 0 T Vo = 18
Revision History

Changes from Original (June 2014) to A Revision Page
LB o= o] F= o= T N o 0 =T [ 3
L o= o] F= o= T N o 0 =TT 3
¢ Changed path t0 C:\TINCC3LO0SDK _1.0.00. 1t uuttiueeiutereeiueesserstssas s sesassssa st s sasssaarssanssansasanesannsns 4
e Added Update SErviCe PACK SECHON. . uuuuuiustiisttiseiitersesase st raas s s saa st s e saa s s s e e aaanesannans 4
* Moved Steps 1 and 8 to Section 3.1, deleted SECON 3.2 ...uuiuiiiiiii i 7
L oo o (=0 1 ] 8
LB O =T g T 1= o o = o 8
LB O =T g T 1= = o 9
L 4 = g Vo =0 N 0T L4 o 11
e Added Tera Term dowWnIOad lINK. ....eeiseiisii s s st s s r s r s e e aannens 14
L U T T o1 (=T o IRV 67T o 000 o= 14
L 4 = g T =0 N 0T L4 o 14
LI U T T o1 (To T 4= o =N 14
LB U T T o (=T T 0= o = 15
¢ Added new download link for sI_common.h fil........uiiueiiiiii 15
¢ Replaced main.c With SI_COMMON.N. ... e e r s r i n e s raan e e s aann e s aannnneeas 15
L o= o] F= o= N o =T [ 16
L Vo [0 1= T0 IS 1= T T o 16
LB O = g T 1= o = o N 17
¢ Replaced main.c With SI_COMMON.N. .. .uuii e e r s a e aanees 17
L 4 = gV =0 N 0T L4 o 17
LI = o] F= o= o N o =T TN 17
L o [0 (=0 B =T o L= oo 1 18
20 Revision History SWRU375B—June 2014 —Revised March 2015

Submit Documentation Feedback
Copyright © 2014-2015, Texas Instruments Incorporated


http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWRU375B

IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, enhancements, improvements and other
changes to its semiconductor products and services per JESD46, latest issue, and to discontinue any product or service per JESDA48, latest
issue. Buyers should obtain the latest relevant information before placing orders and should verify that such information is current and
complete. All semiconductor products (also referred to herein as “components”) are sold subject to TI's terms and conditions of sale
supplied at the time of order acknowledgment.

TI warrants performance of its components to the specifications applicable at the time of sale, in accordance with the warranty in TI's terms
and conditions of sale of semiconductor products. Testing and other quality control techniques are used to the extent Tl deems necessary
to support this warranty. Except where mandated by applicable law, testing of all parameters of each component is not necessarily
performed.

Tl assumes no liability for applications assistance or the design of Buyers’ products. Buyers are responsible for their products and
applications using TI components. To minimize the risks associated with Buyers’ products and applications, Buyers should provide
adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any patent right, copyright, mask work right, or
other intellectual property right relating to any combination, machine, or process in which TI components or services are used. Information
published by TI regarding third-party products or services does not constitute a license to use such products or services or a warranty or
endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual property of the
third party, or a license from Tl under the patents or other intellectual property of TI.

Reproduction of significant portions of Tl information in Tl data books or data sheets is permissible only if reproduction is without alteration
and is accompanied by all associated warranties, conditions, limitations, and notices. Tl is not responsible or liable for such altered
documentation. Information of third parties may be subject to additional restrictions.

Resale of TI components or services with statements different from or beyond the parameters stated by TI for that component or service
voids all express and any implied warranties for the associated TI component or service and is an unfair and deceptive business practice.
Tl is not responsible or liable for any such statements.

Buyer acknowledges and agrees that it is solely responsible for compliance with all legal, regulatory and safety-related requirements
concerning its products, and any use of TI components in its applications, notwithstanding any applications-related information or support
that may be provided by TI. Buyer represents and agrees that it has all the necessary expertise to create and implement safeguards which
anticipate dangerous consequences of failures, monitor failures and their consequences, lessen the likelihood of failures that might cause
harm and take appropriate remedial actions. Buyer will fully indemnify Tl and its representatives against any damages arising out of the use
of any Tl components in safety-critical applications.

In some cases, TI components may be promoted specifically to facilitate safety-related applications. With such components, TI's goal is to
help enable customers to design and create their own end-product solutions that meet applicable functional safety standards and
requirements. Nonetheless, such components are subject to these terms.

No Tl components are authorized for use in FDA Class Ill (or similar life-critical medical equipment) unless authorized officers of the parties
have executed a special agreement specifically governing such use.

Only those Tl components which Tl has specifically designated as military grade or “enhanced plastic” are designed and intended for use in
military/aerospace applications or environments. Buyer acknowledges and agrees that any military or aerospace use of TI components
which have not been so designated is solely at the Buyer's risk, and that Buyer is solely responsible for compliance with all legal and
regulatory requirements in connection with such use.

TI has specifically designated certain components as meeting ISO/TS16949 requirements, mainly for automotive use. In any case of use of
non-designated products, Tl will not be responsible for any failure to meet ISO/TS16949.

Products Applications
Audio www.ti.com/audio Automotive and Transportation www.ti.com/automotive
Amplifiers amplifier.ti.com Communications and Telecom  www.ti.com/communications

Data Converters
DLP® Products

DSP

Clocks and Timers
Interface

Logic

Power Mgmt
Microcontrollers
RFID

OMAP Applications Processors
Wireless Connectivity

dataconverter.ti.com

www.dlp.com

dsp.ti.com
www.ti.com/clocks

interface.ti.com

logic.ti.com

power.ti.com
microcontroller.ti.com

www.ti-rfid.com
www.ti.com/omap

Computers and Peripherals
Consumer Electronics
Energy and Lighting
Industrial

Medical

Security

Space, Avionics and Defense
Video and Imaging

Tl E2E Community

www.ti.com/wirelessconnectivity

www.ti.com/computers

www.ti.com/consumer-apps

www.ti.com/energy
www.ti.com/industrial

www.ti.com/medical

www.ti.com/security
www.ti.com/space-avionics-defense

www.ti.com/video
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